Gateway Logon Page showing Blank (Logon page white screen)

Gateway Logon Page showing Blank (Logon page white screen)

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Article ID: CTX494331

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Updated On:

Description

The logon page of newly added gateway virtual server shows blank, while all the previous configured gateway virtual servers working fine.

Resolution

There are three solutions,

1. Run the follow command to unbind cache policy in related gateway virtual server (invalid after device restart)
unbind vpn vserver [Gateway VS Name] -policy _cacheTCVPNStaticObjects
unbind vpn vserver [Gateway VS Name] -policy _cacheOCVPNStaticObjects
unbind vpn vserver [Gateway VS Name] -policy _cacheVPNStaticObjects
save config

2.Run the following command to disable static cache and reboot Netscaler (All gateway virtual servers will be affected)
set aaa parameter -enableStaticPageCaching NO
save config
reboot

3.If the Netscaler is licensed in platinum edition, enable the integrated cache and expand the cache memory space. ( This new memory limit setting is applied only after you save the configuration and reboot the appliance)
Run the following command to enable integrated cache and expand the memory space.
enable ns feature IC
set cache parameter [-memLimit <MBytes>]
save config
reboot

Note: Memory as required. Ex: 120 or 240


Problem Cause

By default, NetScaler would cache some files(determined by cache policy bind to Gateway Virtual Servers to improve visitor's gateway access experience regardless of NetScaler's Integrated Cache feature unlicensed or disabled. With multi gateway virtual servers configured , the preset cache memory may insufficient for usage and resulting to cache in-completed files. The cached in-completed files will break gateway logon page's normal loading.
You could confirming the in-completed files in Client with Browser's Debug Mode: 
e.g. The rdx.js file is downloaded via ns-cache and it's content length is mismatched. 
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