Unable to type any keyword in the search field when using "Explorer" as a published application

Unable to type any keyword in the search field when using "Explorer" as a published application

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Article ID: CTX492734

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Updated On:

Description

Unable to type or use the search bar when Explorer is used as a Published App. The search works fine for RDP or RDP as Initial App. This affects the search experience for users. 

Resolution

  1. Review and verify all the Windows patches are up to date, MS has released a fix for this bug ( MS Custom Shell - 38134685).
  2. Confirm if we have KB5014021 deployed on the VDA. This KB can't be installed manually, this is part of a Windows update, if the Windows is up to date this should already be installed. 
    1. Verify is the KB is installed on the VDA
  3. Validate if the VDA version is 2203 CU1 or later / CR 2212 or later
  4. Logon to to the VDA, navigate to the registry
    1. HKLM\SOFTWARE\Citrix\Citrix Virtual Desktop Agent 
    2. Create the following registry value name: (value type = REG_DWORD): Shellbridge
      1. Value: 1image.png
  5. Confirm if the updated changes are working or not, publish CMD tool from the affected VDA Server 2022.
    1. Launch the CMD tool and run the command "start ms-settings:printers", this should launch the printer setting window. image.png
    2. The updated changes are working as expected if we observe the Printer settings window, If this is not visible and we encounter any other errors, then the shellbridge key is not effective or the Windows KB is missing. 
    3. We can now launch the published explorer app and Test the behavior of the search field. image.png
  6. If the search is working as expected, we may revert the change w.r.t CMD tool published app. 

Problem Cause

This is caused due to an MS bug and affects Random VMs.
The repro behaviour is also incosistent.