CWA for Chrome OS 23.3.0.40 - keyboard is unresponsive inside the Citrix session

CWA for Chrome OS 23.3.0.40 - keyboard is unresponsive inside the Citrix session

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Article ID: CTX491791

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Updated On:

Description

Symptom 1:

The keyboard is non-responsive when running in Kiosk mode though it is responsive at the Citrix login in kiosk mode (users can enter their username and password) but becomes non-responsive inside the Citrix session. 

Symptom 2: 

  1. Launch CWA for Chrome OS desktop session
  2. Go to the full screen using the toolbar
  3. Press Escape

Expected: Session to remain as is

Observed: Session falls back to Windowed mode. If the session was in multi-monitor mode, it falls back to a single monitor

Further,

  1. Open the Excel application within the session
  2. Do a Ctrl+Shift+Down arrow key shortcut

Expected: Excel column to get selected

Observed: The toolbar is expanded 

Resolution

Citrix Engineering is working to roll out the fix and re-publish the build to the web store. For the interim disable the accessibility feature.

Disable the Accessibility feature by following the below steps,
  1. Navigate to the 'configuration.js' file in the ChromeApp root folder.
  2. Set enable  to false under features -> enable and then save the file
      'features' :
       {
         'accessibility': {
            'enable': false
           },
       }

Problem Cause

This is caused by the accessibility feature in the Workspace app