The registration was refused due to 'Broker Proxy failed to communicate with the cloud DDC.'

The registration was refused due to 'Broker Proxy failed to communicate with the cloud DDC.'

book

Article ID: CTX491163

calendar_today

Updated On:

Description

VDA  machines are getting the list of cloud connectors however they are not getting registered successful.

When checking the event viewer logs, we see error: "The registration was refused due to 'Broker Proxy failed to communicate with the cloud DDC.".
 

Resolution

Ran the cloud health check tool on the VDA - https://docs.citrix.com/en-us/citrix-daas/manage-deployment/cloud-health-check.html

Here you can see the following error: 
image.png

When checking the network settings, it was discovered that the firewall settings for inbound connections on port 80 were allowed but not outbound connections on port 80. 

After making changes on the network end to allow outbound connections on port 80, machines could then register. 

Problem Cause

Issue with network not allowing outbound connections on port 80.

Issue/Introduction

The registration was refused due to 'Broker Proxy failed to communicate with the cloud DDC.'