Desktop cannot access client redirected C: drive after upgrading VDA version to 2203 LTSR

Desktop cannot access client redirected C: drive after upgrading VDA version to 2203 LTSR

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Article ID: CTX489522

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Updated On:

Description

  • Cannot get access to client redirected C$ after upgrading VDA version from 1912 LTSR to 2203 LTSR
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  • Client drive can be seen successfully but VDA cannot get access to it
  • 1912 LTSR VDA works as expected
  • Only change is the upgrade of VDA from 1912 LTSR to 2203 LTSR
  • Client drive has successfully applied onto the problematic 2203 LTSR VDA

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Perform one of the 2 options below:

Option #1 
  1. Disable Virtual Channel allow list  policy from Citrix Studio if DDC has been upgraded to 2203 LTSR.
  2. Reboot the VDA machines for the setting to take effect.

Image_2023-03-13_18-22-34.png

Option#2
  1. Disable Virtual channel allow list policy via the following registry especially if DDC version is still on 1912 LTSR.
  2. Go to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\VCPolicies
Name:VirtualChannelWhiteList
Type:Multi-string
Data:=disabled=

Problem Cause

The third party program try to access our CTXCDM virtual channel and cause the access denied issue.

The logic is related to our Virtual channel allow list policy, which is enabled from 2109 by default. 

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/policies/reference/ica-policy-settings/virtual-channel-allow-list-policy-settings.html