How to correct a VIP not replying after an IP conflict

How to correct a VIP not replying after an IP conflict

book

Article ID: CTX484547

calendar_today

Updated On:

Description

IP conflict errors
VIP not accessible
VIP does not reply ping 

-In this specific scenario there is a host on the network that was statically assigned an IP that the ADC was using on a VIP.

Resolution

After an IP conflict with a Virtual IP, it's possible that the VIP would still not respond, proceed to
  1. Review the device that owns the DHCP pools in the network and verify that ARP table is updated.
  2. From the ADC perspective use the command "send arp all" to send GARP messages to all devices in the network, this will update their ARP tables. this should fix the reachability to the VIP 

Problem Cause

A host on the network is statically assigned an IP that the ADC is using on a VIP.

Issue/Introduction

How to Correct a VIP not replying after an IP conflict

Additional Information

Behavior of Address Resolution Protocol (ARP) and Gratuitous ARP on the NetScaler Device - https://support.citrix.com/article/CTX208384/behavior-of-address-resolution-protocol-arp-and-gratuitous-arp-on-the-netscaler-device

-IP Conflicts
Enter the following command in the shell to view console messages, which include IP address conflicts and duplex mismatch, in the current newnslog file:
nsconmsg -K /var/nslog/newnslog -d consmsg

for conflicts itself use:
nsconmsg -K /var/nslog/newnslog -d consmsg | grep –i “conflict|time”