One client failed on installing CWA due to it failed detecting the Edge Webview2 installation
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Article ID: CTX483697
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Updated On:
Description
One client failed on installing CWA in an intranet environment due to it failed detecting the Edge Webview2 installation. Manually install Webview2 with full-blown installer again still can't fix this issue.
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
Export following registry from the VM which has CWA fresh installed. Then import it back to problematic VM:
- If the previous CWA was installed as an Administrator credential, then Webview2 installation info are stored in:HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\EdgeUpdate\Clients\{F3017226-FE2A-4295-8BDF-00C3A9A7E4C5}
- If previous CWA was installed as a common user, then Webview2 installation info are stored in:HKEY_CURRENT_USER\SOFTWARE\Microsoft\EdgeUpdate\Clients\{F3017226-FE2A-4295-8BDF-00C3A9A7E4C5}
Problem Cause
The "Microsoft Edge Webview2" installation info was missing in registry, which triggers the CWA installer failed on detecting the local "Webview2" installation and always attempting to install it again.
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