Citrix Probe Agent configuration with Cloud errors 'Citrix Trust Service unreachable'

Citrix Probe Agent configuration with Cloud errors 'Citrix Trust Service unreachable'

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Article ID: CTX478848

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Updated On:

Description

Configuring the Citrix Probe Agent to Citrix Cloud gives the Error: "Citrix Trust Service unreachable"

Resolution

Citrix Probe Agent works only when there is no proxy server or load balancer like Citrix Gateway or Citrix ADC deployed.

Problem Cause

The Citrix Probe Agent will fail to connect with the Citrix Trust Service under the following conditions: 

  1. A proxy server or load balancer like Citrix Gateway or Citrix ADC is deployed
  2. An Authentication method such as Single Sign-On (SSO) or Multi-Factor Authentication (MFA) is enabled. Citrix Probe Agent only supports the default form-based authentication as supported by Citrix Workspace.  

Additional Information

https://docs.citrix.com/en-us/citrix-daas/monitor/troubleshoot-deployments/applications/app-probing.html