Addressing the "Down" Status of Secondary ADM Database

Addressing the "Down" Status of Secondary ADM Database

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Article ID: CTX478177

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Updated On:

Description

After upgrading the firmware from ADM13.0-85.19 to ADM13.0-89.7, the customer encountered a problem where the status of the secondary ADM database is marked as "down."

Resolution

To resolve this issue, the following steps should be taken:

  1. Incorporate the secondary node information into the pg_hba.conf file.
  2. Duplicate the pg_hba.conf file from the Primary node to the Secondary node.
  3. Perform a database synchronization using the WebGUI.
       note: If there is a streaming replication error, the Sync Database button appears. You can click the Sync Database button to start the database synchronization process.

Problem Cause

Upon upgrading and observing the secondary ADM database status as "down," it was discovered that the secondary node lacked the pg_hba.conf file located at /var/mps/db_pgsql/data/. Additionally, the content within the pg_hba.conf file on the Primary node did not encompass information about the secondary node. 

Additional Information

https://support.citrix.com/article/CTX327923/how-to-debug-and-resolve-admha-db-streaming-broken-issues