WEM Log displayed in VUEMRSAV.exe not showing correct order of external tasks

WEM Log displayed in VUEMRSAV.exe not showing correct order of external tasks

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Article ID: CTX477673

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Updated On:

Description

When using the VUEMRSAV.exe to determine the outcome of the WEM configuration for a user within the log the order in which the WEM external tasks are executing does not reflect the configured order in the WEM configuration set and also the actual order the external tasks are executing.

Resolution

WEM Agent.log is the preferred and recommended place to check action timings.

You can check %userprofile%\Citrix WEM Agent.log to determine the actual order of execution which are the same as the order you configured for WEM external tasks. The key word t search for in the log us "Processing External Task". 

Problem Cause

By Design. 

The order for WEM external tasks is random in the log displayed in VUEMRSAV.exe, because these tasks are processed in parallel.

Issue/Introduction

When using the VUEMRSAV.exe to determine the outcome of the WEM configuration for a user within the log the order in which the WEM external tasks are executing does not reflect the configured order in the WEM configuration set and also the actual order the external tasks are executing.