Storefront - Unable to access store URL: "Server Error in '/Citrix/#storename#Web' Application"

Storefront - Unable to access store URL: "Server Error in '/Citrix/#storename#Web' Application"

book

Article ID: CTX477503

calendar_today

Updated On:

Description

Security related patches for IE browser and OS were deployed and since then users cannot launch the Storefront page.

The following is displayed: 
Server Error in '/Citrix/#storename#Web' Application.

image.png

 

Resolution

Change the .Net Trust Level to "Full". To toggle this setting: 
  1. Open IIS on Storefront
  2. Click on your site
  3. Select ".Net Trust Levels
  4. Set to Full (internal)
     

image.png


Problem Cause

  • IIS Permission issue.
  • The .Net Trust Level was set to Medium instead of Full.

Issue/Introduction

Full trust for the IIS site is required to load the storefront store