VDA registration fails with an error "The registration was refused due to AgentNotContactable"
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Article ID: CTX477413
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Updated On:
Description
VDA from a specific OU fails to register
Event ID: 1023
Source: Citrix Desktop Service
VDA event logs would state "The registration was refused due to AgentNotContactable"
Environment
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Resolution
- Reset the Local Security Policy to Default in Windows by running the command on the VDA
secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose
- Restart the VDA or run gpupdate /force
Problem Cause
Conflict with the domain security policies
Additional Information
CTX340030 - also resolves the registration issue. However, this might not be applicable to all environments.
You may also refer to the article below for the command used to Reset the Local Security Policy to Default in Windows.
https://learn.microsoft.com/en-us/windows-server/administration/windows-commands/secedit-configure
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