Citrix Websocketservice terminates on startup

Citrix Websocketservice terminates on startup

book

Article ID: CTX477061

calendar_today

Updated On:

Description

Citrix Websocket service terminates on startup. Problem was noticed in VDA 1912 LTSR CU2 and persisted after upgrading to 2203 LTSR CU1. Event logs record the following failure:

Log Name:      Application
Source:        Application Error
Date:          xxxxxxxxxxx
Event ID:      1000
Task Category: Application Crashing Events
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxxxxxxxx
Description:
Faulting application name: WebSocketService.exe, version: 15.32.1100.9, time stamp: 0x62fe4a32
Faulting module name: KERNELBASE.dll, version: 10.0.19041.2006, time stamp: 0xa5d20e5c
Exception code: 0x80000003
Fault offset: 0x00164692
Faulting process id: 0x3220
Faulting application start time: 0x01d90f05c5629bfe
Faulting application path: C:\Program Files (x86)\Citrix\HDX\bin\WebSocketService.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: f5eb06a8-75ef-4c32-a496-6e35b7a92ca0

 

Resolution

Microsoft Forefront TMG was blocking the websocketservice from establishing the I/O connection. Uninstalling Microsoft Forefront TMG resolved the issue. Excluding websocketservice from Forefront TMG might be required for using both products simultaneously.

Problem Cause

Possible failure due to 3rd party products