XenMobile Sever - iOS Devices failing to deploy apps and policies - TOPIC MISMATCH Error

XenMobile Sever - iOS Devices failing to deploy apps and policies - TOPIC MISMATCH Error

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Article ID: CTX475149

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Updated On:

Description

Devices not getting latest changes, and on the XMS Console we see the device information is not up to date (last login, OS version, App Inventory)

On the logs see entries like:

TOPIC MISMATCH  errors
 

2021-10-04T16:03:42.153-0600 | Basic XXXXXXXXX|  WARN | http-nio-10443-exec-3752 | com.sparus.nps.ios.push.IOsPushService | TOPIC MISMATCH - Target ApplePushTarget[os=iOS, device=3722, user=xxxxx@xxxx.xxx.xx, type=DEVICE] was registered with topic 'com.apple.mgmt.External.xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx', but service is currently using topic 'com.apple.mgmt.External.xxxxxxx-xxxxxxxx-xxxx-xxxx-xxxxxxxxxx'. Notifications are unlikely to succeed.

Unable to push apps to the iOS device - Please log in to your iTunes Store account. (Please log in to your iTunes Store account.)
 
2021-09-30T15:04:43.927-0600 | XXXXXXXXX [UID=2772,usr=xxxxxx@xxxx.xxx.xx,dev=4278] |  WARN | http-nio-10443-exec-2510 | com.sparus.nps.apple.push.ApplePush | Could not perform command 'com.zenprise.zdm.push.apple.InstallAppStoreApp' on target ApplePushTarget[os=iOS, device=4278, user=xxxxxx@xxxx.xxx.xx, type=DEVICE]: Error MCMDMErrorDomain-12040: Please log in to your iTunes Store account. (Please log in to your iTunes Store account.)

And multiple STA ticket exceptions
 
2021-10-01T15:26:21.939-0600 | 20d3fa8d6746eaa1  | ERROR | http-nio-18443-exec-143 | com.citrix.xam.bo.sta.STACache | Error retrieving from Cache: com.citrix.xam.bo.sta.TicketNotFoundException: sta ticket xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/xxxxxxx= not found in db

Resolution

Admin needs to renew the same APNs certificate that was already installed on XenMobile.

Problem Cause

Each APNs has a Topic, which is essentially an ID. Topic mismatch error indicate that the ID is different. This error is caused because the admin probably created a new APNs certificate instead of renewing it, or is using another Apple ID

Additional Information

Renewing APNS Certificate - Citrix Docs: https://docs.citrix.com/en-us/xenmobile/server/authentication/apns.html#renew-an-apns-certificate