Citrix Cloud Error: "Invalid username, password or token"

Citrix Cloud Error: "Invalid username, password or token"

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Article ID: CTX473962

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Updated On:

Description

A user cannot login to Citrix Workspace and receives the following error message: “Invalid username, password or token” when logging in.

Resolution

Using the google authenticator app on the phones:
  1. Ensure the Authenticator App is the one used for Time-based One Time Password
  2. The device where the app is installed, date and time should be correct. Ensure the user has "Automatic Date and Time" enabled on thier device settings to pick up the accurate time over network
  3. If the user is trying to enroll their authenticator app using Google Authenticator and is still running into the invalid code issue have them do the following:
  • Click settings.
  • Click "Time correction for codes".
  • Click "Sync Now" and then try again.

Problem Cause

Possible time sync issues with specific devices with Microsoft authenticator