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Article ID: CTX473009
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Updated On:
Description
When attempting to create machine accounts for a newly added domain, you might see "Error: Internal Server Error".
Attempting to use existing machine accounts, you are unable to see anything but the root of the domain.
You have added an on-premise domain in the Identity and Access Management menu.
You have a Cloud Connector installed that appears to be working correctly.

Resolution
After completing all the steps in the documentation to
Connect Active Directory :
- Return to the Identity and Access Management menu (https://citrix.cloud.com/identity/domains)
- Select the checkbox "Show Unused Domains".
- The dialogue will change to "Hide Unused Domains".

- After checking this box, the domain that you added earlier will appear with a graphic box and the options menu added like this:

- Click on the options menu (the three dots), and select "Use domain"

- After this, the domain graphic will turn to colour and the menu option will change to "Disable".
Now, when you attempt to add machine accounts, you will not see the error, but will see the containers in your Active Directory.
Problem Cause
If this is your first time using Citrix DaaS, you might not be aware of the different appearance between fully configured "used" domains and domains that have been added but have not been activated yet. Note in the illustration below, "ourdomain.com" is "used" and "ournewdomain.local" has not yet been activated.