STOREFRONT monitor status DOWN with reason "Probe failed" in NetScaler

STOREFRONT monitor status DOWN with reason "Probe failed" in NetScaler

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Article ID: CTX472842

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Updated On:

Description

customer found the Monitor result show "Probe failed" when binding STOREFRONT monitor to Load balance storefront service.
There is no issue for TCP type monitor.

Resolution

Part of Storefront service is broken. You may contact Citrix Storefront Support engineer for help.

In order to temporarily restore Load Balance production in NetScaler, you may unbind the STOREFRONT type monitor from storefront service and use TCP type monitor instead. 
 

Problem Cause

For STOREFRONT type monitors, ADC will send two http requests (GET /Citrix/Roaming/accounts and GET /Citrix/Store/discovery) to the storefront server, when both http responses returned by storefront server are 200 OK, ADC will consider the monitor result as successful.

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In customer's environment, the http response for request GET /Citrix/Store/discovery is 404 Not Found, so ADC will consider the monitor result as failure.

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