[ADM Service]"failed with error Unable to set capacity" when allocate ADC licence in Cloud

[ADM Service]"failed with error Unable to set capacity" when allocate ADC licence in Cloud

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Article ID: CTX466140

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Description

The newly built ADC VPX could successfully onboarding to Cloud ADM Service. However, when allocate ADC VPX Instance and Bandwidth license to VPX in ADM service GUI page, opeartion failied with below error prompt:
"Failed to set capacity. Reason:[Command failed on *.*.*.* Request to *.*.*.* failed with error Unable to set capacity[Remove and add licenseserver to re-initialize licensing]]

Resolution

Follow below steps to recall the instance license from unmanaged ADC to Citrix ADM Service
1: Login to unmanaged ADC from GUI
2: navigate to configuration>system>license> page.
3: Click "Release allocation" to free ADC instance license and bandwidth license that it consumed.
4: Go back to Citrix ADM Service Page, then allocated recalled instance license and bandwidth license to newly built ADC VPX.

More detailed process may refer below links:
https://docs.citrix.com/en-us/citrix-application-delivery-management-software/current-release/license-server/adc-pooled-capacity/configuring-adc-pooled-capacity.html

Problem Cause

In my case:
Customer imported 45 intances and 60Gbps bandwidth license to Citrix ADM service. There're already 45 ADC instance that already licensed in ADM Service before the newly built ADC VPX added to ADM service. There're 44 active licensed ADC instance from ADM service with 1 unmanaged ADC instance but still consumed instance license.

So, ADM Service has no extra intance license avaliable to allocate.Customer need to recall the instance license from the unmanaged ADC first before re-allocate it to the newly built ADC VPX.

if you login to the newly built ADC that failed to allocate license, below logs you may found in /var/log/ns.logĀ 

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