CVAD - "Access is Denied " error displayed for all new ICA sessions

CVAD - "Access is Denied " error displayed for all new ICA sessions

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Article ID: CTX466084

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Updated On:

Description

"Access is Denied" error pop-up shown when the user launches an ICA session and the logon is in progress.

Environment

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Resolution

The problem was resolved after setting the following registry key to default value on all the Domain Controllers:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

Name: RestrictedRemoteSAM 
Type: REG_SZ
Value: O:BAG:BAD:(A;;RC;;;BA)(A;;RC;;;AU)

Storefront logs the below event

Failed to get user data to determine password expiry, error: 1727 from server <domain controller name>

More information about this key is documented in the following article:

https://learn.microsoft.com/en-us/windows/security/threat-protection/security-policy-settings/network-access-restrict-clients-allowed-to-make-remote-sam-calls

Note: The value for the registry key was taken from a known working Domain controller where this policy was not applied. Customers are advised to consult with Microsoft for determining the appropriate default value for the registry key.


Problem Cause

Problem started after customer's AD team changed the Default Domain Controller policy Network access: Restrict clients allowed to make remote SAM calls. Even after reverting the policy, they were still seeing the issue.

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