Windows 11 22H2, 23H2 & version 24H2 - Citrix Known Issues

Windows 11 22H2, 23H2 & version 24H2 - Citrix Known Issues

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Article ID: CTX464127

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Updated On:

Description

Microsoft releases updates for Windows 11 on an annual feature update cadence. Windows 11 feature updates will release in the second half of the calendar year. The  updates released so far:

  • Windows 11 2022 Update (22H2)
  • Windows 11 2023 Update (23H2)
  • Windows 11 version 24H2 (October 2024)

    This article is intended to capture known issues with Windows 11 22H2 ,23H2 & 24H2 that have been identified so far through Citrix internal testing and customer reports.

    Note:
    • This is a live article and is updated as and when new information is available.
    • Unless an update is specifically mentioned, outlined issues maybe noticed on all versions.
    • Some of the below described issues may be seen with Windows 11 Initial version as well.

 

Known Issues

The following are the known issues:

Issue 1

Issue Description
ICA launch of MCS provisioned VDAs would fail after the Operating system of the master image is upgraded to Win11 22H2 version
[TPV-4753]
 
Problem Cause
MCS machines could not register with the DDC because they cannot get the machine name from the identity disk due to the below registry change upon OS upgrade. The “PvsVMBoot” value in the “BootExecute” multi-string under HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Control\Session Manager is removed during upgrade; i.e “BootExecute”=“autocheck autochk*,PvsVMBoot” gets reset to “BootExecute”=“autocheck autochk*” during the upgrade.

Solution

This issue has been resolved by Microsoft. The resolution can be obtained in one of the following ways:

  • If upgrading to newer Windows version though Windows Update, no action is necessary as the upgrade would contain the fix.
  • If using an ISO to upgrade, one has to choose option 'Download updates, drivers and optional features (recommended)' during the upgrade process for installer to get the fix.
  • If using an ISO, and for any reason, cannot choose 'Download updates, drivers and optional features (recommended)', the fix would need to be downloaded from Microsoft and included into the ISO of the new Windows version intended to be upgraded to. Follow the steps below:

The Windows update listed below have the fixes for the issue and are available as cab files.

Windows 11 (SV1 21H2), KB5020379, Servicing release 2022.11C
https://www.catalog.update.microsoft.com/Search.aspx?q=KB5020379 

Windows 11 (SV2 22H2), KB5019103, Servicing release 2022.10D
https://www.catalog.update.microsoft.com/Search.aspx?q=KB5019103  

Method of installing these updates into your systems: 

  • Download the above .cab file and extract the files using the ‘expand’ command available in Windows shell.
  • Replace the acmigration.dll and appraiser.sdb in the targeted OS installation media with these files from the extracted cab file  (ignore if acmigration.dll is not present)  and run the OS upgrade. 


Follow steps below:

  • Download and copy the cab file to a local folder (eg c:\temp) in your windows machine 
  • Open command prompt as an administrator and run the following commands
For Windows 11 21H1:
cd c:\temp
Expand -f:*  windows10.0-kb5020379-x64_98a445b4b370217a29c7aa5cb708037d144aafb9.cab  c:\temp

For Windows 11 22H2:
cd c:\temp
Expand -f:*  windows11.0-kb5019103-x64_adc8d900add70cc52012a1a221d054759755f5cc.cab  c:\temp 
  • The above operation extracts the contents of the cab file to c:\temp folder. 
  • Open the c:\temp folder and copy two files named “acmigration.dll and appraiser.sdb”.
  • Mount and copy the contents of targeted OS installer to a local folder (eg c:\os )
  • In the “sources” folder replace the acmigration.dll and appraiser.sdb files in the installer by pasting the files copied earlier. 
  • Run the setup file from the local copy of the OS installer and finish the OS upgrade process.

 

Issue 2

Issue Description
The CDF tracing feature may fail to work after upgrading the operating system to Windows 11 22H2 version, on Windows machines with Citrix VDAs
[TPV-4753]

Problem Cause
While upgrading to Win11 22H2 few registry entries required by Citrix CDF tracing feature and few other keys related to VDA get removed under HKLM->System -> CurrentControlSet -> Control ->Citrix. This causes some or all of the modules to be missing in CDF Control.

Solution
This issue has been resolved by Microsoft. The fix is bundled together with other fixes. Follow the Solution outlined for issue 1 in this article.

Workaround
Users are advised to uninstall the Citrix Receiver/VDA and reinstall it.

 

Issue 3

Issue Description
"The trust relationship between this workstation and the primary domain failed" error occurs after MCS VDAs are upgraded from an earlier version of Windows to Windows 11 22H2
[TPV-4769]

Problem Cause
The dependency of "Citrix Pvs VMs agent" service is lost by the upgrade.

Solution

This issue has been resolved by Microsoft. The fix is bundled together with other fixes. Follow the Solution outlined for issue 1 in this article.

 

Issue 4

Issue Description
In-place OS upgrade from Windows 10 22H2 to Windows 11 23H2 with Citrix Virtual Delivery Agent (VDA) 2203 CU3 installed hangs. 
[TPV-5545]

Problem Cause
The in-place OS upgrade process hangs after checking for OS updates.

Solution

This issue has been resolved by Microsoft. Update the system to the latest cumulative update from Microsoft (December 2023 or newer) and then upgrade to Windows 11 23H2. 

 

Issue 5

Issue Description
Some users may experience a Windows Explorer crash and a black screen is seen during session launch on VDA's hosted on Azure.
[TPV-5629]

Problem Cause
There is a known issue related to FSlogix (2201 HF1) that is bundled in Azure market place images of Windows 11. 

Solution

Uninstalling the bundled FSlogix or upgrading it to the latest version will resolve the issue. Citrix is working with Microsoft to resolve the issue in the market place image.

 

Issue 6

Issue Description
On Windows 11 24H2, session launch might fail when anti keylogging feature is enabled with App Protection 
[APPP-3715]

Problem Cause
Changes in Windows 11 version 24H2 is causing this issue 

Solution

A fix for this issue is available with Citrix Workspace App 2405.11 and Citrix Workspace App 2402 CU1 Hotfix 1 (LTSR). These versions are available to download on the following pages:

The issue was also documented on article Session Launch Failure Issue when Anti Keylogging is enabled [Windows 11 24H2 Update]

 

Issue 7

Issue Description

Win 11 24H2 VDAs(single session)/Windows Server 2025 machines are not getting registered when machines created via Provisioning Catalog from Citrix Studio/Powershell commands

[LCM-16630]



Problem Cause
This issue only seen when Win 11 24H2/Server 2025 is provisioned using Provisioning Catalog from Citrix Studio/Powershell commands 

Solution

Citrix is investigating the issue. More details available on CTX692573 

 

Issue 8

Issue Description

Printers from Universal Print Server do not map in the ICA session of Windows 11 VDAs after the VDA OS was upgraded from Windows 10 or Windows 11 older version to newer version; with the VDA in-place.

[LCM-17240]


Problem Cause
While upgrading Windows; few registry entries required for Universal Print mapping are getting removed under HKLM->System -> CurrentControlSet -> Control ->Print-> Providers key.

Solution

There is no solution for this issue currently. Citrix is actively working with Microsoft to resolve the issue. 

Workaround

Before OS upgrade, take a backup of  'HKLM->System->CurrentControlSet->Control->Print->Providers->Order' key and restore it after the OS upgrade is completed. 

OR

Add manually after OS upgrade:

Open registry editor, browse to HKLM->System->CurrentControlSet->Control->Print->Providers->Order, add “Universal Printer, Client Printer” to the existing list.

 

Issue 9

Issue Description

Start menu within a Windows 11 VDI session may not respond for some users after installing Microsoft's December 2024 or newer security updates

[TPV-6122]


Solution

This issue is fixed in the Citrix Virtual Apps and Desktops 7 2503 and newer versions. If users are using LTSR or older versions of Citrix Virtual Apps and Desktops, try the work around mentioned in article CTX692398

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Issue/Introduction

This article is intended to capture known issues with Windows 11 2022 & 2023 Update that have been identified so far through Citrix internal testing and customer reports.