Error while uploading CSR to renew APNS certificate

Error while uploading CSR to renew APNS certificate

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Article ID: CTX463830

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Description

When customer attempts to upload a certificate signing request at https://apnsui.xm.cloud.com/apns, they get an error message saying the upload failed, even though the CSR is created correctly.

Resolution

This can happen if the user attempting to sign the CSR does not have full access to the Citrix cloud account, and has only admin rights to the Endpoint Management tenant. In this case, there are two possible work-arounds to proceed

Option One - Since the user to sign the certificate signing request (CSR) needs "full access" to the Citrix cloud account, not just the Endpoint management section, get another user to sign the CSR.

Option Two - the user can send the CSR to Citrix, we sign it, and the user then completes the process as before.

Problem Cause

The user uploading the CSR did not have required permissions.

Issue/Introduction

When customer attempts to upload a certificate signing request at https://apnsui.xm.cloud.com/apns, they get an error message saying the upload failed, even though the CSR is created correctly.

Additional Information

https://docs.citrix.com/en-us/citrix-endpoint-management/authentication/apns.html