Unable to login HA Secondary ADC with default password after upgrading from 12.1 to 13.0

Unable to login HA Secondary ADC with default password after upgrading from 12.1 to 13.0

book

Article ID: CTX463766

calendar_today

Updated On:

Description

You may using Citrix HA ADC default password in 12.1/11.1 legacy builds, and upgrading an ADC HA Secondary Node to 13.0, then found you cannot login to Secondary Node with default password.
Error: Invalid username or password

Resolution

Solution 1:
Change nsroot default password before upgrade to ADC recent builds.
Solution 2:
Login to Primary node, force failover to Secondary node, you will be able to login to Secondary node with nsroot password and get the correct password change challenges.

Problem Cause

This is a by-design behavior. In recent ADC builds including 12.1, 13.0 and 13.1, ADC will force customer to change the default "nsroot" password.

In HA environment, it is not supported to change nsroot password from Secondary Node. It will prompt invalid username or p

Issue/Introduction

By-design behavior on ADC, please change default password before upgrade, which is also recommended for security concern.