Auto Redirection to Desktop/App list via Gateway stucked in "Detect Citrix Workspace app" page

Auto Redirection to Desktop/App list via Gateway stucked in "Detect Citrix Workspace app" page

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Article ID: CTX463664

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Updated On:

Description

To auto launch desktop, you should ensure Citrix Webhelper work as invoked mode to access desktop/app via Citrix Gateway, please refer to CTX221662 for more details. This need user to encounter "Detect Citrix Workspace app" page to check local installed Citrix Workspace app. If you do not see this page, there are two ways to get to this page:

  • Clear your browser cookies/cache and try again.
  • In Account settings, select "Install Citrix Workspace app"
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When you select "Detect Citrix Workspace app", you will be prompted to Open Citrix Workspace Launcher;
workspace_launcher.png

Click "Open Citrix Workspace Launcher" button, the expected output is that browser will be automatically redirected to Storefront resource enumeration page, which means that Citrix Webhelper work as invoked mode;

However in this case, it stucks at below screen, and webpage doesn't auto redirect to Storefront resource enumeration page, so desktop/app will not launch automatically, instead of downloading ica file.
hang_detect.png

 

Resolution

Configure name server in ADC to ensure ADC can resolve Storefront base URL in ResponseData from STA server, you also need to ensure ADC can initiate TCP connection to the base URL.

Problem Cause

  • Working Scenario
1. Select "Detect Citrix Workspace app" button, browser will send GetDetectionTicket request to Storefront server via Gateway to get STA ticket (Frame 14466 and 14650 );

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2. Click "Open Citrix Workspace Launcher", Webhelper will send STA ticket to Gateway through Socks5 connection (Frame 16059 ~ 16084);
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3. Once receive the STA ticket, ADC will send request POST /Scripts/ctxsta.dll to STA server to validate the ticket ID submitted from the Webhelper, STA server will respond Storefront base url in ResponseData;
image.png

4. ADC resolves the base URL in ResponseData and initiate a TCP connection to it;
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5. Webhelper will collect local workspace information and send request reportDetectionStatus to Storefront via Gateway;
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6. Once received response success status from Storefront, browser will send GetDetectionStatus to Storefront via Gateway, if Storefront responds success, browser will redirect to Storefront resource enumeration page; Citrix Webhelper will work as invoked mode;
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  • Non-working Scenario

In this case, the name server is not configured in ADC, so ADC cannot resolve base url of Storefront in ResponseData and initiate a TCP connection, ADC respond 0x5 error code to browser and disconnect the Socks5 connection;
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Additional Information

https://support.citrix.com/article/CTX221662/how-to-configure-google-chrome-for-citrix-webhelper-invoked-mode