PVS Streamprocess: Login failed (error code: 4) for device <devicename>
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Article ID: CTX463620
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Description
- Target devices are stuck at booting:
- Application event log is flooded with StreamProcess Event ID 10 that reads:
"Login failed (error code: 4) for device targetdevice1: No servers available for disk"
- Application event log will also have Streamprocess event ID 11's which read:
"Detected one or more hung threads. Please send Stream.log to support*."
And
"Terminating StreamProcess."
- Other symptom: You might see the SQL server activity levels (processor / memory) higher than normal.
*Note: There is no Stream.log
Resolution
- Carefully analyze the names of the target devices mentioned in Streamprocess Event ID 10 messages. Look for target device names that appear more frequently. When you have identified a target device name that appears more often than other target devices, power this machine off in the hypervisor.
Tip: Maintenance target devices used to update vDisks are a likely culprit.
Note: Check in Studio to see if this machine is in any catalog or delivery group. To make sure the machine remains powered off, put the machine in maintenance mode.
- Inspect the PVS target device to see what vDisk and version is assigned. If this is the problem, the vDisk or the vDisk version will be missing.
- Assigned a valid vDisk to the target device
Problem Cause
The problem could be caused by even one target device that has a missing vDisk.
The root cause is the SQL server is overloaded by login requests.
It is possible to delete a vDisk or vDisk version that is assigned to a target device. If this happens, and the target device is powered up, the target device will login to each of the PVS servers and request the missing vDisk. It will never stop and can lead to the SQL server being overloaded.
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