Unable to update an MCS catalog in DaaS: "Desktop Studio closed" error

Unable to update an MCS catalog in DaaS: "Desktop Studio closed" error

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Article ID: CTX463514

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Updated On:

Description

Catalog fails to update
Catalog has an exclamation mark alert with a "Desktop Studio closed" message
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Resolution

Use Remote PowerShell SDK to execute the below cmdlets: 
  1. In Remote SDK, run:
    asnp citrix*
    Get-XdAuthentication
    Get-BrokerCatalog -Name <Your catalog name here>
  2. Take note of the "TaskState_..." entry under the MetadataMap parameter:
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  1. Stop that task by running:
Set-BrokerCatalogMetadata -CatalogID <ID of your catalog> -Name TaskState_a9a55b08-cdb3-426b-a39d-d9da6713f2a9 -Value Completed
  1. The alert should disappear, and you can re-try your catalog update.

Problem Cause

Issue might be caused by an error during an update.