Error when changing email address on cloud administrator account

Error when changing email address on cloud administrator account

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Article ID: CTX463477

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Updated On:

Description

An administrator account has been removed and the email address was changed. When attempting to send a new invitation to the updated cloud administrator email, the following error is displayed: 

This invitation's external identity is already being used by an existing admin with a different email
 

Resolution

Recommended solution:
Create a new Azure AD user account with the new email address.  Invite the new administrator with the normal process. 

Other solution:  
  1. Open a Citrix technical support case. Mention the impacted administrator's Azure AD OID and request that the OID is disassociated from the old email address by Citrix Operations.
  2. After the request has been processed, invite the administrator with the normal process. 

Problem Cause

When an Azure AD administrator changes their email address, the administrator's record with the previous email is not being disassociated with the administrator's Azure AD OID.  It must be removed manually by Citrix Operations.

Additional Information

https://docs.citrix.com/en-us/citrix-cloud/citrix-cloud-management/identity-access-management/add-admins.html#invite-individual-administrators