StoreFront Propagate Changes not working
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Article ID: CTX463461
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Updated On:
Description
Running Propagation results in MMC returning "Snap-in Unavailable: This snap-in performed a non-valid operation and has been unloaded [...] Exception Message: Object reference not set to an instance of an object"
In event viewer, Citrix Delivery Services Admin records "Error in retrieving synchronization information. An error occurred running the command: 'Get-DSClusterConfigurationUpdateState' Please make sure you are a member of the CitrixStoreFrontAdministrators Group. Error Details: Access is denied"
Resolution
On all Storefront servers in the Cluster:
- Open Local Users and Groups (lusrmgr.msc)
- Add user to theĀ CitrixStoreFrontAdministrators group
- Log off from the server from which propagation will be initiated, and logon again as the user that has been added.
- Open the Storefront console and propagate changes
Problem Cause
Insufficient privileges. The user was missing in the CitrixStoreFrontAdministrators group on the storefront Servers
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