Intermittently data from Citrix Monitor Database Tables Gets Groomed Unexpectedly
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Article ID: CTX462387
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Updated On:
Description
Intermittently data from Citrix Monitor Database Tables gets groomed unexpectedly.
Resolution
Take regular backups of Citrix Databases.
Check the event logs on Delivery controllers around the time when the data was unexpectedly groomed to see if any events related to losing connectivity to Citrix database is logged.
If you are deliberately causing outage to test LHC then take both Site and Monitor database offline while you test so that Grooming calls fail during that time, preventing the data getting groomed.
This may be as good as stopping the Monitor Service on the DDCs which would also prevent any Grooming calls from being run during that time (the service can be restarted after the test)
Problem Cause
This is generally seen when Delivery Controllers loose connectivity to Citrix Site database as Site Database stores the data Retention configuration.
This connectivity loss to site database can be due to intermittent network or SQL database issues or some customers intentionally forcing outage mode for testing LHC functionality. In outage mode a database disconnect is forced while the Monitor service is still running.
For CVAD versions earlier then 2203 LTSR, in such scenarios the Grooming Retention Days for some Monitor database tables default to Non-Premium licences defaults i.e. 7 days.
With CVAD 2203 LTSR and above, as per current design when there is a transient loss in connectivity to Site database while but Monitor database is still connected and Monitor Service is running then the Grooming Retention days values default to Premium licenses value i.e 90 days to minimize the data loss.