Citrix Cloud-failed to create the computer account due to a problem with active directory

Citrix Cloud-failed to create the computer account due to a problem with active directory

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Article ID: CTX460241

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Updated On:

Description

When creating new machine catalog on Citrix DAAS, machines are not getting added to Active Directory.
Error occurs during catalog creation saying: "failed to create the computer account due to a problem with active directory. This is often caused by the user running Studio not having permissions to create the computer account in the selected OU"

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However, on the AD server you are able to create the machine account using the same account details. 

Resolution

When creating the machine catalog, make sure you are selecting the correct zone and domain. 
The UI will allow you to pick any combo but if you select a zone where the cloud connectors are not located, then it will not work. 

Problem Cause

When creating the machine catalog, the wrong zone was selected which was using different cloud connectors than what is on the domain. 

Issue/Introduction

When creating the machine catalog, the wrong zone was selected which was using different cloud connectors than what is on the domain.