Unable to connect to the server. Contact ... with the following error (no error text available)

Unable to connect to the server. Contact ... with the following error (no error text available)

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Article ID: CTX460224

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Updated On:

Description

1: Via Third party proxy, Workspace report error when launching ICA file "Unable to connect to the server. Contact your system administator with the following error (no error text available)".
2: By Pass Third party proxy, Workspace launching ICA file is successful.

Resolution

Suggest the Third party proxy Do NOT try to parse ICA traffic with HTTP over SSL/TLS protocol validation instead of TCP over SSL/TLS protocol.

Problem Cause

Third party proxy(e.g Nginx) configure HTTP over SSL proxy, However, ICA traffic is TCP over SSL. So it cannot be proxyed correctly.