Issues with published apps sessions still active after closing published app due to WEM agent
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Article ID: CTX460219
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Updated On:
Description
You may see published app sessions active and won't log off.
Environment
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Resolution
1. Check if there is a wfshell process exist in the user's session.
2. Check if "Pin to taskbar" feature is enabled, if so, please disable it and try again.
3. Upgrade WEM agent to 2205 or latest version and see if this issue still exists
If the issue exists, collect the kernel memory dump for further investigation with Citrix Technical Support.
Generate a kernel or complete crash dump
Refer to: https://docs.microsoft.com/en-us/windows/client-management/generate-kernel-or-complete-crash-dump
Problem Cause
The issue is caused if you have VUEMUIAgent.exe running. You may have open Task Manager and Analyze wait chain:

Additional Information
Analyze wait chain: Alternative Tools for Application Hangs
https://techcommunity.microsoft.com/t5/ask-the-performance-team/alternative-tools-for-application-hangs/ba-p/1685245
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