WEM 2203: Citrix WEM Service Citrix.Wem.Agent.Service.exe crash

WEM 2203: Citrix WEM Service Citrix.Wem.Agent.Service.exe crash

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Article ID: CTX460055

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Updated On:

Description

After installing WEM Agent version 2203, the following system events are logged in the VDA: 
Event ID 1026:
.NET Runtime Application: Citrix.Wem.Agent.Service.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. 
and
Event ID 1000:
Faulting application name: Citrix.Wem.Agent.Service.exe, version: 2203.1.0.1, 

Resolution

The local cache for the WEM Agent on the VDA has been corrupted.  Use the following steps to refresh the cache.  The steps can be run as a script.
  1. Stop WEM Agent service on the VDA.
  2. Delete both files under the local database folder here:
    C:\Program Files (x86)\Citrix\Workspace Environment Management Agent\Local Databases
  3. Start WEM Agent service and Netlogon service on the VDA.
  4. Run this the following command: 
     C:\Program Files (x86)\Citrix\Workspace Environment Management Agent\AgentCacheUtility.exe" -refreshcache
  5. Inspect the "Local Databases" folder to see that the database files are re-created. 

Problem Cause

Citrix WEM agent 2203 specific issue causing Citrix.Wem.Agent.Service.exe crash