Logon Duration Is Not Logged In Director For Session Logons Taking More Than 3 Minutes To Complete

Logon Duration Is Not Logged In Director For Session Logons Taking More Than 3 Minutes To Complete

book

Article ID: CTX459861

calendar_today

Updated On:

Description

 Logon Duration not being logged in Database and Director for user logins taking more than 3 mins.


 

Resolution

A private fix has been created which extends this timeout value from 3 mins to infinite.

The private fix will go under further testing and will be included in future cumulative updates of CVAD 2203 LTSR.

If you are experiencing the same issue, please call the Citrix support team to get the issue signature verified and get Private fix CVADHELP-20107 for testing.
 

Problem Cause

  •  Checked and found that Desktop Ready Event ID 1000 was not getting logged on the VDA for the effected user logon.
  • For VDA to send the UPM payload and session logon duration to Delivery controller, it relies on Desktop Ready event 1000 being logged. The root cause for event 1000 not being logged in this case is that logon was taking more than 3 mins and as per code ,UpmEvent.exe has a timeout of 3 mins of waiting for shell(explorer.exe) to get started. In this case we were exceeding the timeout value.
  • If logon does not complete in an ICA session within 3 mins then DesktopReady event ID 1000 is not logged and logon duration payload is not sent to the delivery controller. Reference: https://www.citrix.com/blogs/2013/09/20/director-logon-duration-explained/

 

Additional Information

Virtual Apps and Desktops 7.15.X : Average Logon Duration Is Not Logged For Desktop Sessions in Citrix Director
https://support.citrix.com/article/CTX261857