“Cannot Retrieve Data” on Citrix Director Dashboard error. Unable to see session information .

“Cannot Retrieve Data” on Citrix Director Dashboard error. Unable to see session information .

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Article ID: CTX459737

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Description

“Cannot Retrieve Data” on Citrix Director Dashboard error. Unable to see session information of User Connection Failures, Failed Single-session OS Machines, Failed Multi-session OS Machines data is missing.

The following exception can be seen in CDF traces. 

** Error: “Citrix.Dmc.Common.ConnectorException: Unexpected character encountered while parsing value: <. Path '', line 0, position 0. ---> Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: <. Path '', line 0, position 0.”
 

Resolution

The following steps resolved the issue with 1912 release.

1. Take the backup of the Citrix.Monitor.exe.config file. - C:\Program Files\Citrix\Monitor\Service\Citrix.Monitor.exe.Config
2.Stop the Citrix Monitor service.
3. Add the following text before appSettings in Citrix.Monitor.exe.config file.
   <runtime>
    <generatePublisherEvidence enabled="false" />
    <gcServer enabled="true" />
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
        <dependentAssembly>
        <assemblyIdentity name="Citrix.CloudServices.ServiceRuntime.ApiClient.Core" publicKeyToken="3c7f095e5b8bf519" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-6.0.0.0" newVersion="4.0.0.0" />
        </dependentAssembly>
        </assemblyBinding>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
        <dependentAssembly>
        <assemblyIdentity name="Polly" publicKeyToken="c8a3ffc3f8f825cc" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-7.0.0.0" newVersion="7.0.0.0" />
        </dependentAssembly>
        </assemblyBinding>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
        <dependentAssembly>
        <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-12.0.0.0" newVersion="12.0.0.0" />
        </dependentAssembly>
        </assemblyBinding>
    </runtime>

4. Save the file and start the Citrix Monitor service.
5. Log in to Director

 

Similar issue may occur with different versions of Monitor service.  The assembly binding list may be different in different CVAD versions.

The best way to check if the config file is correct is to compare the content of 2 config files on the Delivery Controller.

Location: C:\Program Files\Citrix\Monitor\Service

Template file: Citrix.Monitor.exe.template

Config file: Citrix.Monitor.exe.Config

You can compare the list of assemblies included in the template and check if the config file contains everything from the template file. If not - it should be updated.

 


Problem Cause

Citrix.Monitor.Exe.Config file had gone corrupt.