After upgrading CWA Chrome to version 2203, when USB device is added to session the device is not available in the session. Message " device is already in use in other session"

After upgrading CWA Chrome to version 2203, when USB device is added to session the device is not available in the session. Message " device is already in use in other session"

book

Article ID: CTX428236

calendar_today

Updated On:

Description

After upgrading to latest CWA for Chrome the end users are not able to connect to USB devices. The message the user sees when trying to manually add the device is that the device is already in use and the transfer button is greyed out.

Resolution

From version 2203, there was a change made where we are redirecting the entire device and also as part of Auto USB Redirection for session in focus the devices that were mapped will get routed to new session if that is in focus.

 

This is an intentional change we did to avoid USB devices from redirecting into multiple sessions the same way as other CWAs work. If the user wants to redirect the device into a new session, It needs to be disconnected from the previous session. 

 

1. To get USB UI dialog : Open connection center widow, select the app session and then click on “Devices” button.

2. Click on “Release All” option in USB UI dialog"

This should be done from first session where you had redirected the devices.


Problem Cause

This is an intentional change we did to avoid USB devices from redirecting into multiple sessions the same way as other CWAs work. If the user wants to redirect the device into a new session, It needs to be disconnected from the previous session. 

Issue/Introduction

After upgrading CWA Chrome to version 2203, when USB device is added to session the device is not available in the session. Message " device is already in use in other session"