How to check ADM agent to endpoint connectivity issue

How to check ADM agent to endpoint connectivity issue

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Article ID: CTX373269

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Description

Issue : Getting the alert message as ADM agent is down.
Tenant ID: XXXXXXX
Agent IP: XXXXXXXX
Agent Host Name: XXXXXXX
Diagnostics Alert:  • https://adm-prod-backup-XXXXXXX.s3.amazonaws.com not reachable

Resolution

      1) Ensure that the following endpoints are whitelisted:

  • Download Service:

    https://download.citrixnetworkapi.net
  • Trust Service:

    *.citrixnetworkapi.net
  • Service URLs:

    *.agent.adm.cloud.com *.adm.cloud.com adm.cloud.com
  • ADC backup service:

    adm-prod-backup-.*\.s3\..*amazonaws\.com




    2) To check the connectivity from ADM agent run the below command

    >Login to ADM agent

    >go to /mps/python/util/, type “python agent_diag.py”, and you can see the details of agent connectivity to ADM endpoints.

    image.png

    3) The alert email should give you details of connectivity issue, apart from that, you can go to /var/mps/log, type “grep send_post_request agent_diag_daemon*”, it should give you all the diagnostic details agent has sent back to the ADM Svc. Please expect to see something like that in the grep result:
    agent_diag_daemon.log.9:TimeStamp=2022-03-07 23:55:41,897 [DEBUG] [MainProcess] 20319 [send_post_request:257]: send_post_request, url=XXXXXXXXXXXX={"mps_agent_diag": {"proxy": 0, "adm": 0, "agent": 0, "trust": 0, "download": 0, "s3": 0, "cas": 0, "pop": "railay", "geo": "", "dns": 0, "grp": 0, "endtime": "Mon March 07 23:55:41 2022", "id": "c2cf5ea4-1212-4ae2-9011-98e045dc509b"}} agent_ip=XXXXXXXcustomer_id=XXXXXXXXX process_name=agent_diag_daemon file_name=/var/mps/log/agent_diag_daemon.log.1

    And these are the diagnostic state definition:
    AGENT_DIAG_STATE_WORKING = 0
    AGENT_DIAG_STATE_NOT_WORKING = 1
    AGENT_DIAG_STATE_NOT_DONE = 2

Problem Cause

URLS not whitelisted

Additional Information

https://docs.citrix.com/en-us/citrix-application-delivery-management-service/system-requirements.html#supported-ports