Citrix High Availability Service failing to start on newly-installed Cloud Connector
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Article ID: CTX369516
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Updated On:
Description
Cloud Connectivity Test returns "unable to validate connectivity [...] The following services are not responding: Broker Service"
The Citrix High Availability Service is not running, and when started manually it crashes.
Application error in event logs:
Faulting module name KERNELBASE.dll [...] Exception code: 0xe0434352
Error details Cannot load Counter Name data because an invalid index 'WorkflowServiceHost 4.0.0.0' was read from the registry.'
Environment
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Resolution
Rebuild windows perfromance counters on the connectors as per https://docs.microsoft.com/en-us/troubleshoot/windows-server/performance/manually-rebuild-performance-counters
To do this:
- Open a command prompt and run the commands below
- cd c:\windows\system32
- lodctr /R
- cd c:\windows\sysWOW64
- lodctr /R
- WINMGMT.EXE /RESYNCPERF
- Stop and restart the Performance Logs and Alerts service.
- Stop and restart the Windows Management Instrumentation service.
- Start the Citrix High Availability Service.
Problem Cause
Performance Counter corruption.
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