Cannot start app **** - Issue when Storefront STA's configure as https.

Cannot start app **** - Issue when Storefront STA's configure as https.

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Article ID: CTX341585

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Updated On:

Description

Issue accessing the url of storefront store through Citrix ADC.
Users are able to access storefront, but when users try to open any application it gives an error: Cannot start app ****
However, when accessing the storefront url internally using store URL, all the applications open without problems, After checking Storefront event viewer,  events can be seen related to the STA's that are generated after giving an error when accessing storefront environment. EventId 28 - Warning - Citrix Store Service EventId 1003 - Error - Citrix Store Service EventId 0 - Error - Citrix Store Service Within the Storefront STA's are configured same as in the Citrix ADC “HTTPS”, .
. If you switch to "HTTP" on Storefront STA's configuration, apps open without issue,
Followed this article https://support.citrix.com/article/CTX218986, but issue continues.

Resolution

Changed in Storefront configuration manage gateways STAs to FQDN and propagated changes

Problem Cause

In Storefront configuration manage gateways STAs configured with IP address and delivery controllers with FQDN