ELM : When we click on upgrade and try to browse we get the error : there was an error on processing web request : status code 400 (bad Request ) : Bad Request

ELM : When we click on upgrade and try to browse we get the error : there was an error on processing web request : status code 400 (bad Request ) : Bad Request

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Article ID: CTX341521

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Updated On:

Description

Error : there was an error on processing web request : status code 400 (bad Request ) : Bad Request

Resolution

When a task is force-canceled, there is no clean-up performed, so temporary disks can be left in the Layering Service repository. You need to manually delete these. You can do this by logging in as root, or through any file manager like WinSCP or FileZilla.

Files can be left in one of these two folders:

  1. /mnt/repository/Unidesk/Packaging Disks
  2. /mnt/repository/Unidesk/Layered Images
  • If no tasks are running, then there should be no files in either folder. If there are tasks running, please allow them to complete or be canceled before proceeding.

Here is an example of "ls -l" with two force-canceled layer edit tasks, one for a layer named TEST APP and one for a layer named TEST. Since those tasks have already been force-canceled, you can delete all 4 files back and get 23GB back in your repository.

/mnt/repository/Unidesk/Packaging Disks

total : 1234567890

-rw-r--r-- 1 root root 10752833024 Feb 6 15:53 TEST APPBoot.vhd

-rw-r--r-- 1 root root 138452480 Feb 6 15:53 TEST APPPkg.vhd

-rw-r--r-- 1 root root 12619631104 Feb 6 12:09 TESTBoot.vhd

-rw-r--r-- 1 root root 203496448 Feb 6 12:09 TESTPkg.vhd

  • Similarly, here are four temporary files for publishing operations which were not cleaned up properly. Again, if there are no running tasks, you can safely delete these files.

/mnt/repository/Unidesk/Layered Images:

Total : 1234567890

-rw-r--r-- 1 root root 37246370304 Dec 19 18:33 XXXXXXX

-rw-r--r-- 1 root root 37246370304 Dec 19 17:58 XXXXXXX

-rw-r--r-- 1 root root 37147780096 Dec 5 13:07 XXXXXXXX

-rw-r--r-- 1 root root 38611949568 Oct 16 09:31 XXXXXXXXX


NOTE:
-------

If you happen to delete any of these files while a task is running, the task will fail. But subsequent tasks will run normally.

-- Be sure all tasks that can be canceled have been checked

 Refer : https://support.citrix.com/article/CTX234410

-- If issue still persists perform following steps:

systemctl stop maservice

 

First connect to

MySQL:mysql -uroot -proot MAData

 

Then run these SQL commands:

delete from WorkItemContext;

update WorkItem Join WorkTicket on wtiWorkTicketId = wtId SET wtiState = 'Canceled' WHERE wtiState not in('Complete', 'Failed', 'Canceled');

update WorkItem Set wtiUserActionPerformed = 0 Where wtiUserActionPerformed != 0;

delete from StoredRegisteredTask;

 

Reboot the ELM and check the task queue from the web console.


Problem Cause

  • Large heap in SQL 
  • Staled Tasks 
  • Pending Tasks 
  • Forced cancelled Tasks 

Additional Information

https://discussions.citrix.com/topic/412540-could-not-communicate-with-the-management-service-please-verify-the-health-of-the-enterprise-layer-manager/page/2/