Citrix Workspace App for windows - Microphone not detected in MS Teams through HP laptop

Citrix Workspace App for windows - Microphone not detected in MS Teams through HP laptop

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Article ID: CTX341471

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Updated On:

Description

When utilizing Microsoft Teams optimization through Citrix Workspace, Teams is unable to access the built-in microphone, despite other applications detecting it without issues

Resolution

Possible Solutions:

  1. Upgrade to Citrix Workspace 2103.1 or a later version, as this may resolve the issue.

  2. If upgrading is not feasible or does not fix the problem, create the following registry key on the client PC:

    • Location: Computer\HKEY_CURRENT_USER\Software\Citrix\HDXMediaStream
    • Key: DisableADM2
    • Type: REG_DWORD
    • Value: 1

Ensure that you restart the client machine to apply the registry key changes correctly.

Then, start an ICA session and verify if Microsoft Teams functions as expected.

Note: Make sure webrpc.dll and wertc_codecs.dll are unblocked. To do this, right-click on the exe file, select 'Properties', and choose the 'Unblock' option if available.


 


Problem Cause

The HP driver is unable to be set to two-channel audio, which is required for the Teams optimization feature to function properly.