No sound when reconnecting to XenApp Sessions

No sound when reconnecting to XenApp Sessions

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Article ID: CTX340190

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Updated On:

Description

On reconnect to XenApp Sessions it is not possible to hear any audio and the audio channel is not active

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Set the following registry value on the VDA to clean up the cached device map info and other related data held on the VDA on session disconnect
 
HKLM\Software\Citrix\Audio & HKLM\Software\Wow6432Node\Citrix\Audio
DWORD CleanMappingWhenDisconnect
value 1
 

Problem Cause

Audio devices are not correctly recreated on disconnect and reconnect