Citrix Gateway plugin takes time to load after updating Chrome/Edge to version 98

Citrix Gateway plugin takes time to load after updating Chrome/Edge to version 98

book

Article ID: CTX340098

calendar_today

Updated On:

Description

The Citrix Gateway plugin for Windows  takes time to connect and the Browser stays on the Download prompt for some time ( for ~1 minute ) as shown below

image.png
At the same time, the browser developer tools and Console will display the following errors 

image.png

image.png

Resolution

Citrix has identified the issue and released a new Gateway plugin: https://www.citrix.com/en-in/downloads/citrix-gateway/plug-ins/citrix-gateway-windows-plug-in-clients.html

Please upgrade the plugin to avoid the issue.

macOS:

Not impacted as for MacOS, VPN plugin is not supported and Citrix SSO is recommended. Citrix SSO does not support browser-based login, hence not impacted by this update.

Problem Cause

From Chromev98 or Edge v98, any requests to the private network are being treated similar to cross-domain requests and thereby chrome/edge sends a preflight ( Request Method is Option ) request and expects certain headers in the response,

The new plugins mentioned above are able to handle Preflight requests.

Additional Information

https://support.citrix.com/article/CTX339975