Unable to Logon to Workspace Application externally, throws error "Unable to connect to the server"
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Article ID: CTX339593
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Updated On:
Description
Unable to connect to the server on Citrix workspace client when logging into it. It throws an error "unable to connect to the server". This happens on the Citrix Workspace app. However, when we use the workspace URL on the browser, then, we can authenticate successfully and also launch apps/desktops from it.
Resolution
Renamed the hostname of the machine to contain characters less than or equal to 15 to also keep it same and complaint with NetBIOS names too.
Problem Cause
The client name of the machine/endpoint which had workspace installed had a hostname character count exceeding 20 characters. This limitation is specified in the Citrix blog -
https://www.citrix.com/blogs/2015/07/01/rewriting-the-session-clientname-from-storefront/
Additional Information
It will also log an event on the Storefront server with Event ID 27 and the description of that event is logged when authentication fails as "Invalid client device information supplied by a client using the address: x.x.x.x. The client name 'xyz' or device id 'abc' are null, over-length or contain invalid characters"
You may use the command "ipconfig" to find the hostname and count the characters to see if it is exceeding the count of 20 characters.
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