Published Desktop session stuck at grey screen on session launch

Published Desktop session stuck at grey screen on session launch

book

Article ID: CTX338582

calendar_today

Updated On:

Description

  • Published Desktop session stuck at grey screen on session launch.
  • You may see Citrix CTXUVI error events in Windows system Event logs with ID 1003/1005 on Citrix VDAs (CTXUVI Driver Injection failure).

Environment

Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.

Resolution

If you observe issue on the VDAs with Antivirus enabled, configure all the Antivirus exclusions as perĀ https://docs.citrix.com/en-us/tech-zone/build/tech-papers/antivirus-best-practices.html

If you are using Trend Micro, please upgraded to v20 or Later.


Problem Cause

It is a security feature when CtxUvi.sys hooking driver detects any tampering with (meaning modification of) any of the Citrix Hook registry hives or Citrix Hook DLL files, it immediately disables all Citrix Hooking. In such a case, the symtoms could be published Desktop session stuck at grey screen on session launch.