Citrix PVS soap server service does not start and crashes after installing Microsoft January 2022 Updates (E.g. KB5008877 or KB5009546)

Citrix PVS soap server service does not start and crashes after installing Microsoft January 2022 Updates (E.g. KB5008877 or KB5009546)

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Article ID: CTX338544

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Updated On:

Description

  • Since installing Microsoft January 2022 Updates like KB5009546 or KB5008877 the Citrix PVS soap server service doesn't start anymore.
  • When trying to start this service it crashes right away.
  • While this happens the Citrix PVS API service also stops working.
  • Soapserver.exe crashes Event 1000 .net event 1026 after Jan Server monthly updates
  • ConfigWizard.exe crash when used.
Note: This issue occurs even if the updates are only applied to Active Directory Domain Controllers and not yet applied to the PVS server.

Environment

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Resolution

Microsoft has made .NET updates available around 7th February after which the this issue is no longer observed. The updates addresses an issue where after the January 11th Security update and/or the January 18th update is installed, applications that leverage .NET Framework System.DirectoryServices APIs specific to acquiring or setting Forest Trust Information may fail or crash with various errors, including an access violation.

The following workaround may help prevent the error and can safely be removed once the server has been patched:
  • Set the following registry key on the PVS server and reboot or restart the soap server:
HKLM\Software\Citrix\ProvisioningServices. Value Name: SkipForestLevelTrusts (DWORD) Value: 1
 
Please apply the Microsoft fix based on your operating system and version of PVS and what version of .NET framework it shipped with.  For example:

1.  If you are running PVS 1912 CU4, that versions ships with .NET 4.7.x.  On Windows 2016 in order to resolve this matter you would have to apply: KB5011329
2.  If you are running PVS 2112, that version ships with .NET 4.8.x.  On Windows 2016 in order to resolve this matter you would have to apply: KB5011264

To find out what version of .NET that your version of PVS ships with please look in the Product documentation guide under System requirements and compatibility

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*The .NET 4.7.2 fix can be used for .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 or 4.7.2 whenever applicable
 

Problem Cause

The issue is caused by Microsoft updates. 

The below Updates have been validated:
50112635011329501125950112665011264501125750112585011261
For more information, refer to January Security Update Validation report CTX338561

Additional Information

 https://discussions.citrix.com/topic/415259-pvs-services-crash-after-updates