Workspace App for Mac HDX Connections May Fail after Update of Microsoft Defender for Endpoint on Client

Workspace App for Mac HDX Connections May Fail after Update of Microsoft Defender for Endpoint on Client

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Article ID: CTX338543

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Updated On:

Description

An HDX/ICA session via Citrix Workspace App for Mac to either a published desktop or published application may fail after Microsoft Defender for Endpoint is updated to version 101.54.16 on the Mac client.

This will also only occur if Citrix EDT (Enlightened Data Transport) for UDP based HDX/ICA connections is enabled for the Site.

The specific error observed will be the connection will indicate it is "Starting" and eventually timeout.   See sample below:

Sample Error

Resolution

The following two workarounds are available for mitigation of this issue:

1. Disable EDT for the site or for the client.  Connections will default back to TCP based which will work even with the 101.54.16 version of Microsoft Defender for Endpoint.
 
2. Utilize Workspace App for HTML5 via the Browser.  These connections do not use UDP and thus will be unaffected by this issue.

Problem Cause

This issue is under active investigation by both Citrix and Microsoft and this article will be updated as more information becomes available.