Error: "Invalid File Format" while submitting a CSR on tools.xm.citrix.com
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Article ID: CTX338535
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Updated On:
Description
When submitting the CSR the Admin Receives: "Error: Invalid File format"
CSR is generated via IIS according to the documentation: https://docs.citrix.com/en-us/xenmobile/server/authentication/apns.html
Resolution
Remove any punctuation from the filename of the CSR and submit the Signing request again.
Specifically, there must be no "." (period) character in the file name other than the period before the extension .txt or .csr - File names with two or more periods will fail.
Additionally, you should use uppercase letters A-Z, lowercase letters a-z, and digits 0-9 ONLY, avoiding accented characters or any other punctuation or symbols.
Problem Cause
File filename includes punctuation that is causing the error.
Issue/Introduction
CSR submitted to the Citrix Tools page should not have punctuation.
Additional Information
https://docs.citrix.com/en-us/xenmobile/server/authentication/apns.html
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