CCC tool output shows HTTP Status 87, parameter incorrect
book
Article ID: CTX335759
calendar_today
Updated On:
Description
Ran the Cloud Connector Connectivity Checker > https://support.citrix.com/article/CTX260337 and it says it failed on HTTP STATUS 87

Environment
This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.
Resolution
As marked in the screenshot above, Access Type 3 means the tool is using Proxy but does not have the proxy defined. This is the reason why we are getting return code 87 (Also the error message Parameter is incorrect is indication of this).
Note: Access type: 1 points to Direct Internet and No Proxy.
Solution
To use the Netsh.exe tool to remove a proxy server and to configure "direct access" to the Internet, follow these steps:
1. Click Start
2. Click Run
3. Type cmd
4. Click OK
5. At the command prompt, type below command and press ENTER
netsh winhttp reset proxy
Problem Cause
Proxy was enabled but not specified. After changing to direct it started working.
Issue/Introduction
Ran the Cloud Connector Connectivity Checker and it says it failed on HTTP STATUS 87
Was this article helpful?
thumb_up
Yes
thumb_down
No