Diagnostic data to collect for Citrix Tech Support when a Citrix Browser App fails to launch

Diagnostic data to collect for Citrix Tech Support when a Citrix Browser App fails to launch

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Article ID: CTX335754

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Updated On:

Description

To find out what is going wrong when a Citrix browser app fails to launch, tech support needs:

  • Decrypted Fiddler traces,
  • the output from the terminal window, and
  • Citrix Browser debug logs. 

Environment

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Resolution

Read through the entire instructions before starting.  There is no VDA to collect traces.  Receiver Diagnostic data is not helpful.

Do not forget to tidy up when finished if the client computer is a static or persistent machine. 

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Prepare the client machine that is failing to launch the Citrix Browser application:

  1. Download Fiddler from here:  https://www.telerik.com/download/fiddler/fiddler4
  2. Install Fiddler.  The executable will throw up a warning about the app "isn't a Microsoft-verified app".  Choose "Install anyway"
  3. Add this registry key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\CitrixBrowser 
    1. Add a string name--> WorkspaceBrowserCmdLineArgs 
    2. This whole string is the value data including the two hyphens at the start-->    --enable-logging --log-level=0
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\CitrixBrowser

Steps to collect the traces: 

  1. On the client machine that is prepared as above, Log into Citrix Workspace.  Do not launch the Citrix Browser app yet.
  2. Open Fiddler.
    1. Press F12 to stop the capturing that begins automatically.  (File-->Capture Traffic)
    2. Enable Decrypt HTTPS traffic.  Tools-->Options-->HTTPS→Enable Decrypt HTTPS traffic.   You will be warned that this requires installation of Fiddler root certs, so when you see the prompts, allow these.  See the series of scary messages that will be shown at the bottom of this document.
FiddlerDecrypt.JPG
  1. Press F12 to start Fiddler capture.
  2. Launch the failing Citrix Browser App.
  3. A terminal window will open behind the browser launch.  The contents of this window need to be copied to a Notepad file.  Do not delay.  This terminal window stays open for about 15 seconds.  When the graphical error appears, this window is closed. 
    1. It has the title "C:\Program Files (x86)\Citrix\ICA Client\CitrixBrowser\CitrixBrowser.exe". 
    2. Right-click the title bar, choose "Select All", then again and choose "Copy". 
    3. Paste the contents of this terminal windows into a Notepad file. 
Sample of Terminal Window that opens for diagnostic data collection.
  1. Get the CitrixBrowser debug log. 
    1. ​​​​Immediately open %localappdata%\Citrix\CitrixBrowser\UserData\CitrixBrowser_debug.log.
    2. Copy the entire contents to a new text file. 
    3. Note:  If you launch a new Citrix Browser app, this file is immediately overwritten, so do not delay to capture the contents of this file.
  2. Focus on the Fiddler window. 
    1. Press F12 to stop the collection.
    2. Choose File-->Save-->All Sessions

Collect all three files: 

--the text from the terminal window,

--the CitrixBrowser_debug.log,

---The Fiddler trace file

Include in one zip file.  Upload the zip file containing all three files to https://support.citrix.com/case/manage 

IMPORTANT CLEANUP STEPS!!!  

If the client machine that was used is a static or persistent machine, perform these important steps to reverse the changes made to collect the diagnostic data.  

1) Clear the 'Enable Decrypt HTTPS' check box in Fiddler:    Tools-->Options-->HTTPS→Enable Decrypt HTTPS traffic.  

2) Remove the extra registry string value "WorkspaceBrowserCmdLineArgs" from HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\CitrixBrowser 

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Problem Cause

Based on error message shown in the extra terminal windows, Applocker Policy on windows is blocking launch of native-bridge

Issue/Introduction

If a Citrix Browser app fails to launch, first verify that the executables for Citrix Browser are not being blocked by Anti-Virus or Applocker. Citrix Tech Support may request diagnostic data to be collected to progress your case and might point you to this article to complete these steps.

Additional Information

These are the messages that are shown when enabling HTTPS decryption: 
scary.JPG
RootName_DO_NOT_Trust.JPG
Third-warning.JPG