StoreFront deployments to Cloud Analytics not showing up in the Control Plane

StoreFront deployments to Cloud Analytics not showing up in the Control Plane

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Article ID: CTX335748

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Updated On:

Description

StoreFront Deployments to Cloud Analytics not Showing up in the Control Plane It looks like we need to open a new case for an issue that we’re seeing when onboarding our StoreFront Deployments to Cloud Analytics. We’re trying to add our 7 Prod StoreFront Deployments and only 6 of them are showing up in the Control Plane.

Resolution

  1. There should be a unique ClusterId per server group, Change one of the ClusterIDs  by generating a unique GUID.
    • It can be generated using an online tool such as https://www.uuidgenerator.net
      1. Go to the Storefront server machine in a Server Group and navigate to the path: C:\Program Files\Citrix\Receiver StoreFront\Framework\FrameworkData\Framework.xml
      2. Take a backup of the original Framework.xml.
      3. Edit the Framework.xml file and change the ClusterID value with the new GUID
      4. Edit Framework.xml file on all the servers in one group and update the ClusterID with the new GUID.
        • Note: Use same GUID for all the servers in one group.
  2. Restart Citrix Storefront service from Windows services. Do this for all the servers.
  3. Connect the StoreFront deployment in Citrix Analytics
    • Login to CAS UI and navigate to Settings > Data Sources. Connect the StoreFront deployment following the steps in our documentation: Onboard Virtual Apps and Desktops Sites using StoreFront
  4. Refresh Data Sources UI to see the newly onboarded StoreFront
  5. Verify that the Storefront deployment key in CAS UI is same as ClusterID value from Framework.xml

Problem Cause

  • Configuration Issue
  • Same Cluster ID on multiple Server Groups

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